about summary refs log tree commit diff
path: root/users/fcuny/desktop/sway.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/fcuny/desktop/sway.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/users/fcuny/desktop/sway.nix b/users/fcuny/desktop/sway.nix
deleted file mode 100644
index 0f1631e..0000000
--- a/users/fcuny/desktop/sway.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-{
-  imorts = [
-    ./swayidle.nix
-    ./wofi.nix
-  ]
-
-  home.packages = with pkgs; [
-    pavucontrol
-    wofi
-    wl-clipboard
-    wf-recorder
-  ];
-
-  home.sessionVariables = {
-    MOZ_ENABLE_WAYLAND = true;
-    LIBSEAT_BACKEND = "logind";
-  };
-
-  wayland.windowManager.sway = {
-    enable = true;
-    systemdIntegration = true;
-    wrapperFeatures.gtk = true;
-    config = rec {
-      modifier = "Mod4";
-      terminal = "${config.programs.alacritty.package}/bin/alacritty";
-      menu = "${pkgs.wofi}/bin/wofi -S run";
-    };
-    defaultWorkspace = "workspace number 1";
-    startup = [
-      # Initial lock
-      { command = "${pkgs.swaylock-effects}/bin/swaylock"; }
-      # Start idle daemon
-      { command = "${pkgs.swayidle}/bin/swayidle -w"; }
-      # Start waybar
-      { command = "${pkgs.waybar}/bin/waybar"; }
-    ];
-  };
-}