about summary refs log tree commit diff
path: root/users/fcuny/desktop/media/sync-music.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/fcuny/desktop/media/sync-music.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/users/fcuny/desktop/media/sync-music.nix b/users/fcuny/desktop/media/sync-music.nix
deleted file mode 100644
index 85e795a..0000000
--- a/users/fcuny/desktop/media/sync-music.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ config, pkgs, ... }:
-
-{
-  systemd.user.services.sync-music = {
-    Unit = {
-      Description = "synchronize my music collection to the NAS";
-      Documentation = "man:rsync(1)";
-      ConditionFileIsExecutable = "${pkgs.rsync}/bin/rsync";
-      ConditionHost = "carmel";
-    };
-    Service = {
-      Type = "oneshot";
-      ExecStart = "${pkgs.rsync}/bin/rysnc -avz -t %h/media/music/ nas.home:/data/music";
-    };
-  };
-
-  systemd.user.timers.sync-music = {
-    Unit = {
-      Description = "synchronize my music collection to the NAS";
-      Documentation = "man:rsync(1)";
-    };
-    Timer = {
-      OnBootSec = "120m";
-      OnUnitActiveSec = "1d";
-      RandomizedDelaySec = "1800";
-      Persistent = true;
-    };
-    Install = { WantedBy = [ "timers.target" ]; };
-  };
-}