about summary refs log tree commit diff
path: root/users/fcuny/desktop/media/mpd.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/fcuny/desktop/media/mpd.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/users/fcuny/desktop/media/mpd.nix b/users/fcuny/desktop/media/mpd.nix
deleted file mode 100644
index a779158..0000000
--- a/users/fcuny/desktop/media/mpd.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ config, pkgs, ... }:
-
-{
-  home.packages = [
-    pkgs.mpd
-    pkgs.ncmpcpp
-  ];
-
-  xdg.configFile."ncmpcpp/config".source = ../../configs/ncmpcpp/config;
-
-  services.mpd = {
-    enable = true;
-    musicDirectory = config.xdg.userDirs.music;
-    network.startWhenNeeded = true;
-    extraConfig = ''
-      auto_update "yes"
-      filesystem_charset "UTF-8"
-      zeroconf_enabled "no"
-      input {
-        plugin "curl"
-      }
-      audio_output {
-        type "pipewire"
-        name "PipeWire Sound Server"
-      }
-      audio_output {
-        type   "fifo"
-        name   "visualizer"
-        path   "/tmp/mpd.fifo"
-        format "44100:16:2"
-      }
-    '';
-  };
-}