about summary refs log tree commit diff
path: root/users/fcuny/desktop/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/desktop/default.nix')
-rw-r--r--users/fcuny/desktop/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/users/fcuny/desktop/default.nix b/users/fcuny/desktop/default.nix
index 9f0bcf3..3a1e21a 100644
--- a/users/fcuny/desktop/default.nix
+++ b/users/fcuny/desktop/default.nix
@@ -9,6 +9,7 @@
     ./terminal.nix
     ./gtk.nix
     ./xdg.nix
+    ./trust
   ];
 
   home.packages = [
@@ -17,4 +18,18 @@
     pkgs.gnome3.nautilus
     pkgs.transmission-remote-gtk
   ];
+
+  environment = {
+    sessionVariables = {
+      TERMINAL = [ "alacritty" ];
+      TERM = [ "xterm-256color" ];
+    };
+
+    # Activate home-manager environment, if not already enabled
+    loginShellInit = ''
+      [ -d "$HOME/.nix-profile" ] || /nix/var/nix/profiles/per-user/$USER/home-manager/activate &> /dev/null
+    '';
+    homeBinInPath = true;
+    localBinInPath = true;
+  };
 }