about summary refs log tree commit diff
path: root/users/fcuny/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/default.nix')
-rw-r--r--users/fcuny/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/users/fcuny/default.nix b/users/fcuny/default.nix
new file mode 100644
index 0000000..21413e0
--- /dev/null
+++ b/users/fcuny/default.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+{
+
+  programs.home-manager.enable = true;
+
+  home.packages = [
+    pkgs.jq
+    pkgs.ripgrep
+  ];
+
+  home.sessionVariables = {
+    LANG = "en_US.UTF-8";
+    LC_CTYPE = "en_US.UTF-8";
+    LC_ALL = "en_US.UTF-8";
+    EDITOR = "vim";
+  };
+
+  imports = [
+    ./git.nix
+    ./go.nix
+    ./tmux.nix
+    ./zsh.nix
+  ];
+}