about summary refs log tree commit diff
path: root/users/fcuny/cli/tools.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/cli/tools.nix')
-rw-r--r--users/fcuny/cli/tools.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/users/fcuny/cli/tools.nix b/users/fcuny/cli/tools.nix
new file mode 100644
index 0000000..bd38c72
--- /dev/null
+++ b/users/fcuny/cli/tools.nix
@@ -0,0 +1,12 @@
+{ pkgs, config, lib, ...}:
+
+{
+  environment.systemPackages = with pkgs; [
+    # use the correct version of `perf` for the configured `linuxPackages`
+    linuxpkgs.perf
+    perf-tools
+    flameGraph
+  ];
+  # this uses  correct `linuxPackages` for `bcc`
+  programs.bcc.enable = true;
+}