about summary refs log tree commit diff
path: root/users/fcuny/cli/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/cli/git.nix')
-rw-r--r--users/fcuny/cli/git.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/users/fcuny/cli/git.nix b/users/fcuny/cli/git.nix
deleted file mode 100644
index 8afb7ec..0000000
--- a/users/fcuny/cli/git.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{ lib, config, ... }:
-
-let inherit (lib) mkIf;
-in {
-  programs.git = {
-    enable = true;
-    aliases = {
-      s = "status --short --branch";
-      amend = "commit --amend --no-edit";
-    };
-    extraConfig = {
-      core.whitespace = "trailing-space,space-before-tab";
-      color.ui = "true";
-      push.default = "simple";
-      init.defaultBranch = "main";
-      branch.autosetuprebase = "remote";
-      branch.sort = "authordate";
-    };
-    userName = "Franck Cuny";
-    userEmail = "franck@fcuny.net";
-    extraConfig = {
-      "credential \"https://github.com\"" = { username = "fcuny"; };
-      "credential \"https://git.fcuny.net\"" = { username = "fcuny"; };
-    };
-    ignores = [
-      "*.elc"
-      "*.iml"
-      "*.o"
-      "*.pyc"
-      "*.pyo"
-      "*pyc"
-      "*~"
-      ".DS_Store"
-      ".\\#"
-      ".dir-locals.el"
-      ".direnv/*"
-      ".idea"
-      ".projectile"
-      ".pytest_cache/"
-      "/env/*"
-      "Icon"
-      "TAGS"
-      "\\#*\\#"
-      "tags"
-    ];
-  };
-}