about summary refs log tree commit diff
path: root/users/fcuny/cli/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/cli/git.nix')
-rw-r--r--users/fcuny/cli/git.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/users/fcuny/cli/git.nix b/users/fcuny/cli/git.nix
new file mode 100644
index 0000000..f7aeb27
--- /dev/null
+++ b/users/fcuny/cli/git.nix
@@ -0,0 +1,40 @@
+{
+  programs.git = {
+    enable = true;
+    aliases = {
+      s = "status --short --branch";
+      amend = "commit --amend --no-edit";
+    };
+    extraConfig = {
+      core.whitespace = "trailing-space,space-before-tab";
+      color.ui = "true";
+      push.default = "simple";
+      init.defaultBranch = "main";
+      branch.autosetuprebase = "remote";
+      branch.sort = "authordate";
+    };
+    userName = "Franck Cuny";
+    userEmail = "franck@fcuny.net";
+    ignores = [
+      "*.elc"
+      "*.iml"
+      "*.o"
+      "*.pyc"
+      "*.pyo"
+      "*pyc"
+      "*~"
+      ".DS_Store"
+      ".\\#"
+      ".dir-locals.el"
+      ".direnv/*"
+      ".idea"
+      ".projectile"
+      ".pytest_cache/"
+      "/env/*"
+      "Icon"
+      "TAGS"
+      "\\#*\\#"
+      "tags"
+    ];
+  };
+}