about summary refs log tree commit diff
path: root/users/fcuny/cli/beets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/fcuny/cli/beets.nix')
-rw-r--r--users/fcuny/cli/beets.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/users/fcuny/cli/beets.nix b/users/fcuny/cli/beets.nix
new file mode 100644
index 0000000..6c3b53b
--- /dev/null
+++ b/users/fcuny/cli/beets.nix
@@ -0,0 +1,18 @@
+{ config, lib, pkgs, ... }:
+
+{
+  programs.beets = {
+    enable = true;
+    settings = {
+      directory = "/data/fast/music";
+      plugins = "fromfilename duplicates fetchart badfiles scrub";
+      paths = { default = "$albumartist/$album%aunique{}/$track $title"; };
+      import = { copy = true; };
+      va_name = "Various Artists";
+      fetchart = {
+        cautious = true;
+        sources = "filesystem coverart itunes amazon lastfm wikipedia";
+      };
+    };
+  };
+}