about summary refs log tree commit diff
path: root/tools/sendsms/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/sendsms/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/sendsms/default.nix b/tools/sendsms/default.nix
new file mode 100644
index 0000000..6c9b79c
--- /dev/null
+++ b/tools/sendsms/default.nix
@@ -0,0 +1,15 @@
+{ pkgs, naersk, ... }:
+
+naersk.lib."${pkgs.system}".buildPackage {
+  src = builtins.filterSource
+    (path: type:
+      type != "directory" || builtins.baseNameOf path != "target")
+    ./.;
+
+  nativeBuildInputs = with pkgs; [ pkg-config ];
+  buildInputs = with pkgs; [ openssl ];
+
+  remapPathPrefix = true;
+  doCheck = true;
+  copyLibs = true;
+}