about summary refs log tree commit diff
path: root/tools/perf-flamegraph-pid/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/perf-flamegraph-pid/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tools/perf-flamegraph-pid/default.nix b/tools/perf-flamegraph-pid/default.nix
new file mode 100644
index 0000000..d3b3e1e
--- /dev/null
+++ b/tools/perf-flamegraph-pid/default.nix
@@ -0,0 +1,24 @@
+{ lib, stdenvNoCC, pkgs, config }:
+
+stdenvNoCC.mkDerivation rec {
+  pname = "perf-flamegraph-pid";
+  src = ./perf-flamegraph-pid.sh;
+  version = "0.1.0";
+
+  nativeBuildInputs = with pkgs; [ flamegraph linuxPackages_latest.perf ];
+
+  dontUnpack = true;
+  dontBuild = true;
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp $src $out/bin/${pname}
+  '';
+
+  meta = with lib; {
+    description = "Generate a process' flame graph.";
+    license = with licenses; [ mit ];
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ fcuny ];
+  };
+}