about summary refs log tree commit diff
path: root/tools/music-organizer/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/music-organizer/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/music-organizer/default.nix b/tools/music-organizer/default.nix
new file mode 100644
index 0000000..1242e34
--- /dev/null
+++ b/tools/music-organizer/default.nix
@@ -0,0 +1,15 @@
+{ pkgs, ... }:
+
+pkgs.buildGoModule rec {
+  name = "music-organizer";
+  src = ./.;
+  vendorSha256 = "sha256-pQpattmS9VmO3ZIQUFn66az8GSmB4IvYhTTCFn6SUmo=";
+  nativeBuildInputs = with pkgs; [ go ];
+
+  meta = with pkgs.lib; {
+    description = "CLI to organize my music in folders.";
+    license = licenses.mit;
+    platforms = platforms.linux;
+    maintainers = [ ];
+  };
+}