about summary refs log tree commit diff
path: root/tools/govanity/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tools/govanity/flake.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tools/govanity/flake.nix b/tools/govanity/flake.nix
index 15b13d0..d2c2254 100644
--- a/tools/govanity/flake.nix
+++ b/tools/govanity/flake.nix
@@ -21,6 +21,16 @@
           nativeBuildInputs = with pkgs; [ go ];
         };
 
+        apps = {
+          deploy = pkgs.pkgs.writeShellScriptBin "run-deploy" ''
+            set -euxo pipefail
+            export PATH=${
+              pkgs.lib.makeBinPath [ pkgs.go pkgs.git pkgs.jq pkgs.flyctl ]
+            }:$PATH
+            bash ./scripts/deploy.sh
+          '';
+        };
+
         devShell = with pkgs;
           mkShell { nativeBuildInputs = [ git go gopls golangci-lint bash ]; };
       });