about summary refs log tree commit diff
path: root/profiles/wm/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/wm/default.nix')
-rw-r--r--profiles/wm/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/profiles/wm/default.nix b/profiles/wm/default.nix
new file mode 100644
index 0000000..7b1fe39
--- /dev/null
+++ b/profiles/wm/default.nix
@@ -0,0 +1,18 @@
+{ config, lib, ... }:
+let cfg = config.my.profiles.wm;
+in {
+  options.my.profiles.wm = with lib; {
+    windowManager = mkOption {
+      type = with types; nullOr (enum [ "sway" ]);
+      default = null;
+      example = "sway";
+      description = "Which window manager to use";
+    };
+  };
+  config = lib.mkMerge [
+    (lib.mkIf (cfg.windowManager == "sway") {
+      # Enable sway
+      my.home.wm.windowManager = "sway";
+    })
+  ];
+}