about summary refs log tree commit diff
path: root/profiles/samba.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/samba.nix')
-rw-r--r--profiles/samba.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/profiles/samba.nix b/profiles/samba.nix
deleted file mode 100644
index 4ae8839..0000000
--- a/profiles/samba.nix
+++ /dev/null
@@ -1,33 +0,0 @@
-{ config, pkgs, lib, ... }:
-let
-  makePublicShare = path: {
-    name = builtins.baseNameOf path;
-    value = {
-      inherit path;
-      browseable = "yes";
-      writeable = "no";
-      "guest ok" = "yes";
-      "guest only" = "yes";
-      "force user" = "nobody";
-    };
-  };
-  publicShares = [ "/data/fast/music" "/data/fast/videos" ];
-in
-{
-  # https://github.com/NixOS/nixpkgs/blob/master/nixos/modules/services/network-filesystems/samba.nix
-  services.samba = {
-    enable = true;
-    extraConfig = ''
-      workgroup = WORKGROUP
-      server string = tahoe
-      netbios name = tahoe
-      security = user
-      guest account = nobody
-      mangled names = no
-      client min protocol = SMB2
-      map to guest = bad user
-      ntlm auth = true
-    '';
-    shares = with lib; (listToAttrs (map makePublicShare publicShares));
-  };
-}