about summary refs log tree commit diff
path: root/profiles/nginx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/nginx.nix')
-rw-r--r--profiles/nginx.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/profiles/nginx.nix b/profiles/nginx.nix
deleted file mode 100644
index e32106f..0000000
--- a/profiles/nginx.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ pkgs, lib, config, ... }:
-{
-  services.nginx = {
-    enable = true;
-
-    # For monitoring scraping. If we don't set a default port, it will
-    # by default use port 80, which will conflict with the
-    # configuration of the router, since we need to listen on port 80
-    # too for streaming.
-    statusPage = true;
-    defaultHTTPListenPort = 8008;
-
-    recommendedGzipSettings = true;
-    recommendedOptimisation = true;
-    recommendedTlsSettings = true;
-    recommendedProxySettings = true;
-  };
-
-  services.prometheus.exporters.nginx = {
-    enable = true;
-    scrapeUri = "http://127.0.0.1:${toString config.services.nginx.defaultHTTPListenPort}/nginx_status";
-    listenAddress = "127.0.0.1";
-    port = 9113;
-  };
-
-  # Nginx needs to be able to read the certificates
-  users.users.nginx.extraGroups = [ "acme" ];
-
-  networking.firewall.allowedTCPPorts = [ 80 443 ];
-}