about summary refs log tree commit diff
path: root/profiles/laptop/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--profiles/laptop/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/profiles/laptop/default.nix b/profiles/laptop/default.nix
new file mode 100644
index 0000000..f5288b6
--- /dev/null
+++ b/profiles/laptop/default.nix
@@ -0,0 +1,15 @@
+{ config, lib, ... }:
+let cfg = config.my.profiles.laptop;
+in {
+  options.my.profiles.laptop = with lib; {
+    enable = mkEnableOption "laptop profile";
+  };
+
+  config = lib.mkIf cfg.enable {
+    # monitors and controls temperature
+    my.services.thermald.enable = true;
+
+    # Enable TLP power management
+    my.services.tlp.enable = true;
+  };
+}