about summary refs log tree commit diff
path: root/profiles/bluetooth/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--profiles/bluetooth/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/profiles/bluetooth/default.nix b/profiles/bluetooth/default.nix
new file mode 100644
index 0000000..ffd05b4
--- /dev/null
+++ b/profiles/bluetooth/default.nix
@@ -0,0 +1,9 @@
+{ config, lib, ... }:
+let cfg = config.my.profiles.bluetooth;
+in {
+  options.my.profiles.bluetooth = with lib; {
+    enable = mkEnableOption "bluetooth profile";
+  };
+
+  config = lib.mkIf cfg.enable { my.hardware.bluetooth.enable = true; };
+}