about summary refs log tree commit diff
path: root/nix/users/fcuny/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/ssh.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/nix/users/fcuny/ssh.nix b/nix/users/fcuny/ssh.nix
index 2129650..004d44f 100644
--- a/nix/users/fcuny/ssh.nix
+++ b/nix/users/fcuny/ssh.nix
@@ -1,4 +1,5 @@
-{ ... }: {
+{ ... }:
+{
   # https://github.com/nix-community/home-manager/blob/master/modules/programs/ssh.nix
   programs.ssh = {
     enable = true;
@@ -12,26 +13,34 @@
         hostname = "github.com";
         user = "git";
         forwardAgent = false;
-        extraOptions = { preferredAuthentications = "publickey"; };
+        extraOptions = {
+          preferredAuthentications = "publickey";
+        };
       };
       "github.rbx.com" = {
         hostname = "github.rbx.com";
         user = "git";
         forwardAgent = false;
-        extraOptions = { preferredAuthentications = "publickey"; };
+        extraOptions = {
+          preferredAuthentications = "publickey";
+        };
       };
       "git" = {
         hostname = "git.fcuny.net";
         port = 422;
         user = "git";
         forwardAgent = false;
-        extraOptions = { preferredAuthentications = "publickey"; };
+        extraOptions = {
+          preferredAuthentications = "publickey";
+        };
       };
       "home" = {
         hostname = "fcuny.net";
         port = 422;
         user = "fcuny";
-        extraOptions = { preferredAuthentications = "publickey"; };
+        extraOptions = {
+          preferredAuthentications = "publickey";
+        };
       };
     };
   };