about summary refs log tree commit diff
path: root/nix/users/fcuny/nixos.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nix/users/fcuny/nixos.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nix/users/fcuny/nixos.nix b/nix/users/fcuny/nixos.nix
new file mode 100644
index 0000000..662c0b1
--- /dev/null
+++ b/nix/users/fcuny/nixos.nix
@@ -0,0 +1,20 @@
+{ pkgs, ... }: {
+  # https://github.com/nix-community/home-manager/pull/2408
+  environment.pathsToLink = [ "/share/fish" ];
+
+  # Add ~/.local/bin to PATH
+  environment.localBinInPath = true;
+
+  # we're using fish as our shell
+  programs.fish.enable = true;
+
+  users.users.fcuny = {
+    isNormalUser = true;
+    home = "/home/fcuny";
+    extraGroups = [ "docker" "wheel" ];
+    shell = pkgs.fish;
+    openssh.authorizedKeys.keys = [
+      "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAINBkozy+X96u5ciX766bJ/AyQ3xm1tXZTIr5+4PVFZFi"
+    ];
+  };
+}