about summary refs log tree commit diff
path: root/nix/users/fcuny/k8s.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/users/fcuny/k8s.nix')
-rw-r--r--nix/users/fcuny/k8s.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/nix/users/fcuny/k8s.nix b/nix/users/fcuny/k8s.nix
index 5461142..88a7350 100644
--- a/nix/users/fcuny/k8s.nix
+++ b/nix/users/fcuny/k8s.nix
@@ -25,10 +25,14 @@
   };
 
   programs.fish = {
+    shellAbbrs = {
+      k = "kubectl";
+      kctx = "kubie ctx";
+      klogs = "kubectl logs";
+    };
     shellAliases = {
-      ukctx = ''
-        GH_HOST=github.rbx.com ${pkgs.gh}/bin/gh api "repos/Roblox/cell-lifecycle/contents/rks/kubeconfig" --jq '.content' | base64 -d > ~/.kube/rksconfig
-      '';
+      ukctx =
+        "${pkgs.gh}/bin/gh api --hostname github.rbx.com repos/Roblox/cell-lifecycle/contents/rks/kubeconfig --jq '.content' | base64 -d > ~/.kube/rksconfig";
     };
   };
 }