about summary refs log tree commit diff
path: root/nix/profiles/home-manager/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/profiles/home-manager/shell.nix')
-rw-r--r--nix/profiles/home-manager/shell.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nix/profiles/home-manager/shell.nix b/nix/profiles/home-manager/shell.nix
index dfa7f7a..1166bac 100644
--- a/nix/profiles/home-manager/shell.nix
+++ b/nix/profiles/home-manager/shell.nix
@@ -53,6 +53,8 @@
     LESSCHARSET = "utf-8";
     PAGER = "less";
     ASPELL_CONF = "conf ${config.xdg.configHome}/aspell/config;";
+    # for some reason, if I don't set this, zsh is picked up and mess up stuff.
+    SHELL = "${pkgs.fish}/bin/fish";
   };
 
   programs.alacritty = {
@@ -85,6 +87,7 @@
     baseIndex = 1;
     shortcut = "z";
     clock24 = true;
+    shell = "${pkgs.fish}/bin/fish";
     historyLimit = 50000; # Bigger buffer
     extraConfig = ''
       setw -g mouse on