about summary refs log tree commit diff
path: root/nix/profiles/home-manager/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/profiles/home-manager/shell.nix')
-rw-r--r--nix/profiles/home-manager/shell.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/nix/profiles/home-manager/shell.nix b/nix/profiles/home-manager/shell.nix
index 2f86232..fe7e4ff 100644
--- a/nix/profiles/home-manager/shell.nix
+++ b/nix/profiles/home-manager/shell.nix
@@ -54,49 +54,6 @@
     SHELL = "${pkgs.fish}/bin/fish";
   };
 
-  programs.alacritty = {
-    enable = true;
-    settings = {
-      env = {
-        TERM = "xterm-256color";
-      };
-      shell = {
-        program = "${pkgs.fish}/bin/fish";
-        args = [
-          "--login"
-          "-c"
-          "tmux attach -t base || tmux new -s base"
-        ];
-      };
-      font = {
-        normal.family = "Monaspace Argon";
-        bold = { style = "Bold"; };
-        size = 16;
-      };
-    };
-  };
-
-  programs.tmux = {
-    enable = true;
-    terminal = "xterm-256color";
-    escapeTime = 0;
-    aggressiveResize = true;
-    baseIndex = 1;
-    shortcut = "z";
-    clock24 = true;
-    shell = "${pkgs.fish}/bin/fish";
-    historyLimit = 50000; # Bigger buffer
-    extraConfig = ''
-      setw -g mouse on
-
-      # Avoid date/time taking up space
-      set -g status-right ""
-      set -g status-right-length 0
-
-      set-option -g renumber-windows on
-    '';
-  };
-
   programs.direnv = {
     enable = true;
     nix-direnv.enable = true;