about summary refs log tree commit diff
path: root/nix/profiles/home-manager/personal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/profiles/home-manager/personal.nix')
-rw-r--r--nix/profiles/home-manager/personal.nix37
1 files changed, 2 insertions, 35 deletions
diff --git a/nix/profiles/home-manager/personal.nix b/nix/profiles/home-manager/personal.nix
index 165edcf..dd4c9f9 100644
--- a/nix/profiles/home-manager/personal.nix
+++ b/nix/profiles/home-manager/personal.nix
@@ -1,4 +1,4 @@
-{ pkgs, self, ... }: {
+{ ... }: {
 
   home.stateVersion = "23.05";
 
@@ -6,6 +6,7 @@
     ./dev.nix
     ./firefox.nix
     ./git.nix
+    ./shell.nix
     ./ssh.nix
     ./zsh.nix
   ];
@@ -13,38 +14,4 @@
   programs.git = {
     userEmail = "franck@fcuny.net";
   };
-
-  home.packages = with pkgs; [
-    direnv
-    jless
-    jq
-    nixd
-    nix-direnv
-    nixfmt
-    nixpkgs-fmt
-    ripgrep
-    rnix-lsp
-    tree
-    self.packages.${pkgs.system}.seqstat
-  ];
-
-  home.sessionVariables = {
-    EDITOR = "emacsclient -a=";
-    VISUAL = "emacsclient -a=";
-    LESS = "-FRSXM";
-    LESSCHARSET = "utf-8";
-    PAGER = "less";
-  };
-
-  programs = {
-    direnv = {
-      enable = true;
-      nix-direnv.enable = true;
-      enableZshIntegration = true;
-      config = {
-        global.disable_stdin = true;
-        global.strict_env = true;
-      };
-    };
-  };
 }