about summary refs log tree commit diff
path: root/nix/mkSystem.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/mkSystem.nix')
-rw-r--r--nix/mkSystem.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/nix/mkSystem.nix b/nix/mkSystem.nix
deleted file mode 100644
index bf141da..0000000
--- a/nix/mkSystem.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-inputs@{ self, ... }:
-{ system ? "x86_64-linux", hostname, }:
-let
-  naersk = inputs.naersk.lib."${system}";
-in
-inputs.nixpkgs.lib.nixosSystem {
-  inherit system;
-  specialArgs = { inherit inputs system hostname self; };
-  modules = [
-    "${self}/modules"
-    "${self}/hosts/${hostname}"
-    "${self}/modules/homelab"
-    "${self}/modules/private-wireguard.nix"
-    {
-      networking.hostName = hostname;
-      nixpkgs = {
-        config.allowUnfree = true;
-        overlays = [
-          inputs.nur.overlay
-          inputs.rust.overlays.default
-          (final: prev:
-            {
-              tools = import "${self}/tools" { pkgs = prev; inherit naersk; };
-            })
-        ];
-      };
-    }
-  ];
-}