about summary refs log tree commit diff
path: root/nix/mkHomeManagerConfiguration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nix/mkHomeManagerConfiguration.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/nix/mkHomeManagerConfiguration.nix b/nix/mkHomeManagerConfiguration.nix
new file mode 100644
index 0000000..bcf374a
--- /dev/null
+++ b/nix/mkHomeManagerConfiguration.nix
@@ -0,0 +1,28 @@
+inputs@{ self, ... }:
+{ system ? "x86_64-linux"
+, username ? "fcuny"
+, hostname
+, stateVersion ? "22.05"
+, extraModules ? [ ]
+,
+}:
+inputs.home-manager.lib.homeManagerConfiguration {
+  inherit system;
+  inherit username;
+  inherit stateVersion;
+
+  homeDirectory = "/home/${username}";
+
+  pkgs = import inputs.nixpkgs {
+    inherit system;
+    config.allowUnfree = true;
+    overlays = [
+      inputs.emacs-overlay.overlay
+      inputs.nur.overlay
+      inputs.rust.overlays.default
+      (final: prev: { tools = import "${self}/tools" { pkgs = prev; }; })
+    ];
+  };
+  configuration.imports =
+    [ "${self}/home" "${self}/hosts/${hostname}/home.nix" ];
+}