about summary refs log tree commit diff
path: root/nix/machines/vm-aarch64/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nix/machines/vm-aarch64/default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/nix/machines/vm-aarch64/default.nix b/nix/machines/vm-aarch64/default.nix
index 302a80c..b1444cc 100644
--- a/nix/machines/vm-aarch64/default.nix
+++ b/nix/machines/vm-aarch64/default.nix
@@ -1,5 +1,12 @@
 { ... }: {
   imports = [ ./hardware.nix ../vm-shared.nix ];
 
+  # Use the systemd-boot EFI boot loader.
+  boot.loader.systemd-boot.enable = true;
+  boot.loader.efi.canTouchEfiVariables = true;
+
   networking.hostName = "vm-aarch64";
+
+  # enable the guest agent
+  services.qemuGuest.enable = true;
 }