about summary refs log tree commit diff
path: root/nix/machines/vm-aarch64.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nix/machines/vm-aarch64.nix17
1 files changed, 1 insertions, 16 deletions
diff --git a/nix/machines/vm-aarch64.nix b/nix/machines/vm-aarch64.nix
index 8e84ed5..1c2e479 100644
--- a/nix/machines/vm-aarch64.nix
+++ b/nix/machines/vm-aarch64.nix
@@ -1,16 +1 @@
-{ ... }: {
-  imports = [ ./hardware/vm-aarch64-utm.nix ./vm-shared.nix ];
-
-  # Interface is this on my M1
-  networking.interfaces.enp0s10.useDHCP = true;
-
-  # Qemu
-  services.spice-vdagentd.enable = true;
-
-  # For now, we need this since hardware acceleration does not work.
-  environment.variables.LIBGL_ALWAYS_SOFTWARE = "1";
-
-  # Lots of stuff that uses aarch64 that claims doesn't work, but actually works.
-  nixpkgs.config.allowUnfree = true;
-  nixpkgs.config.allowUnsupportedSystem = true;
-}
+{ ... }: { imports = [ ./hardware/vm-aarch64-utm.nix ./vm-shared.nix ]; }