about summary refs log tree commit diff
path: root/nix/hosts/darwin/macos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/darwin/macos.nix')
-rw-r--r--nix/hosts/darwin/macos.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/nix/hosts/darwin/macos.nix b/nix/hosts/darwin/macos.nix
deleted file mode 100644
index 36f680a..0000000
--- a/nix/hosts/darwin/macos.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ pkgs, ... }: {
-  system.defaults.dock.autohide = true;
-  system.defaults.dock.orientation = "left";
-  system.defaults.dock.showhidden = false;
-  system.defaults.dock.show-recents = false;
-  # don’t rearrange spaces based on the most recent use
-  system.defaults.dock.mru-spaces = false;
-  system.defaults.finder.AppleShowAllExtensions = true;
-  system.defaults.screencapture.location = "~/Documents/screenshots";
-  system.defaults.SoftwareUpdate.AutomaticallyInstallMacOSUpdates = true;
-
-  fonts.packages = with pkgs; [
-    emacs-all-the-icons-fonts
-    google-fonts
-    roboto
-    source-code-pro
-    source-serif-pro
-    source-sans-pro
-    go-font
-  ];
-
-  system.keyboard = {
-    enableKeyMapping = true;
-    remapCapsLockToControl = true;
-  };
-
-  # Touch ID for sudo auth
-  security.pam.enableSudoTouchIdAuth = true;
-
-  services.nix-daemon.enable = true;
-
-  system.defaults.CustomUserPreferences = {
-    "com.apple.desktopservices" = {
-      # Avoid creating .DS_Store files on network or USB volumes
-      DSDontWriteNetworkStores = true;
-      DSDontWriteUSBStores = true;
-    };
-  };
-}