about summary refs log tree commit diff
path: root/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nix/default.nix36
1 files changed, 1 insertions, 35 deletions
diff --git a/nix/default.nix b/nix/default.nix
index 8b46c58..2dfd8a2 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -1,39 +1,5 @@
 { inputs }:
 
 {
-  mkSystem =
-    { hostname
-    , system
-    }:
-    inputs.nixpkgs.lib.nixosSystem {
-      inherit system;
-      specialArgs = {
-        inherit inputs system hostname;
-      };
-      modules = [
-        ../modules
-        ../hosts/${hostname}
-        ./private-wireguard.nix
-        {
-          networking.hostName = hostname;
-          nixpkgs = {
-            config.allowUnfree = true;
-            overlays = [
-              inputs.emacs-overlay.overlay
-              inputs.nur.overlay
-              (final: prev: {
-                tools = {
-                  gerrit-hook = import ../tools/gerrit-hook final;
-                };
-              })
-            ];
-          };
-          # Add each input as a registry
-          nix.registry = inputs.nixpkgs.lib.mapAttrs'
-            (n: v:
-              inputs.nixpkgs.lib.nameValuePair (n) ({ flake = v; }))
-            inputs;
-        }
-      ];
-    };
+  mkSystem = import ./mkSystem.nix inputs;
 }