about summary refs log tree commit diff
path: root/nix/checks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/checks.nix')
-rw-r--r--nix/checks.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/nix/checks.nix b/nix/checks.nix
deleted file mode 100644
index aadb170..0000000
--- a/nix/checks.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ pkgs, pre-commit-hooks, ... }:
-
-with pkgs;
-
-{
-  pre-commit-check = pre-commit-hooks.lib.${system}.run {
-    src = lib.cleanSource ../.;
-    hooks = {
-      nix-linter.enable = true;
-      nixpkgs-fmt.enable = true;
-      trailing-whitespace = {
-        enable = true;
-        entry =
-          "${pkgs.python3Packages.pre-commit-hooks}/bin/trailing-whitespace-fixer";
-        types = [ "text" ];
-      };
-      end-of-file-fixer = {
-        enable = true;
-        entry =
-          "${pkgs.python3Packages.pre-commit-hooks}/bin/end-of-file-fixer";
-        types = [ "text" ];
-      };
-      terraform-format = { enable = true; };
-      shellcheck = {
-        enable = true;
-        files = "\\.sh$";
-        types_or = [ "file" ];
-      };
-    };
-  };
-}