about summary refs log tree commit diff
path: root/modules/system/security/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/system/security/ssh.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/system/security/ssh.nix b/modules/system/security/ssh.nix
new file mode 100644
index 0000000..14cbf5d
--- /dev/null
+++ b/modules/system/security/ssh.nix
@@ -0,0 +1,17 @@
+{ ... }:
+
+{
+  programs.ssh = {
+    # $ ssh-keyscan example.com
+    knownHosts = {
+      github = {
+        hostNames = [ "github.com" ];
+        publicKey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIOMqqnkVzrm0SdG6UOoqKLsabgH5C9okWi0dh2l9GKJl";
+      };
+      rsync = {
+        hostNames = [ "de2664.rsync.net" ];
+        publicKey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIObQN4P/deJ/k4P4kXh6a9K4Q89qdyywYetp9h3nwfPo";
+      };
+    };
+  };
+}