about summary refs log tree commit diff
path: root/modules/services/monitoring/grafana.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/monitoring/grafana.nix')
-rw-r--r--modules/services/monitoring/grafana.nix78
1 files changed, 0 insertions, 78 deletions
diff --git a/modules/services/monitoring/grafana.nix b/modules/services/monitoring/grafana.nix
deleted file mode 100644
index 4407354..0000000
--- a/modules/services/monitoring/grafana.nix
+++ /dev/null
@@ -1,78 +0,0 @@
-{ config, lib, pkgs, ... }:
-let
-  cfg = config.my.services.monitoring.grafana;
-  secrets = config.age.secrets;
-in
-{
-  options.my.services.monitoring.grafana = with lib; {
-    enable = mkEnableOption "grafana observability stack";
-    vhostName = mkOption {
-      type = types.str;
-      example = "dash.fcuny.net";
-      description = "Name for the virtual host";
-    };
-  };
-
-  config = lib.mkIf cfg.enable {
-    services.grafana = {
-      enable = true;
-      settings = {
-        security.adminUser = "fcuny";
-        analytics.reporting_enabled = false;
-        server.http_port = 4000;
-        server.http_addr = "127.0.0.1";
-      };
-      provision = {
-        enable = true;
-        datasources.settings.datasources = [
-          {
-            name = "prometheus";
-            type = "prometheus";
-            isDefault = true;
-            url = "http://${config.my.services.monitoring.prometheus.listenAddress}:${toString config.my.services.monitoring.prometheus.listenPort}";
-          }
-          {
-            name = "loki";
-            url = "https://loki.${config.homelab.domain}";
-            type = "loki";
-          }
-        ];
-        dashboards.settings.providers = [{
-          disableDeletion = true;
-          options.path = ./dashboards;
-        }];
-      };
-    };
-
-    services.nginx.virtualHosts."${cfg.vhostName}" = {
-      forceSSL = true;
-      useACMEHost = config.homelab.domain;
-      listen = [
-        {
-          addr = "192.168.6.40";
-          port = 443;
-          ssl = true;
-        }
-        {
-          addr = "192.168.6.40";
-          port = 80;
-          ssl = false;
-        }
-      ];
-      locations."/" = {
-        proxyPass = "http://${config.services.grafana.settings.server.http_addr}:${
-            toString config.services.grafana.settings.server.http_port
-          }";
-        proxyWebsockets = true;
-      };
-    };
-
-    my.services.backup = {
-      paths = [ "/var/lib/grafana" ];
-      exclude = [
-        "/var/lib/grafana/data/log/"
-        "/var/lib/grafana/log/"
-      ];
-    };
-  };
-}