about summary refs log tree commit diff
path: root/modules/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/modules/default.nix b/modules/default.nix
new file mode 100644
index 0000000..0885f69
--- /dev/null
+++ b/modules/default.nix
@@ -0,0 +1,23 @@
+{ lib, ... }:
+
+{
+  imports = [ ./hardware ./system ./services ./home ./programs ./secrets ];
+
+  options.my = with lib; {
+    user = {
+      name = mkOption {
+        type = types.str;
+        default = "fcuny";
+        example = "franck";
+        description = "my username";
+      };
+
+      home = {
+        enable = mkEnableOption {
+          description = "home-manager configuration";
+          default = true;
+        };
+      };
+    };
+  };
+}