about summary refs log tree commit diff
path: root/lib/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/lib/default.nix b/lib/default.nix
deleted file mode 100644
index 8b46c58..0000000
--- a/lib/default.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ inputs }:
-
-{
-  mkSystem =
-    { hostname
-    , system
-    }:
-    inputs.nixpkgs.lib.nixosSystem {
-      inherit system;
-      specialArgs = {
-        inherit inputs system hostname;
-      };
-      modules = [
-        ../modules
-        ../hosts/${hostname}
-        ./private-wireguard.nix
-        {
-          networking.hostName = hostname;
-          nixpkgs = {
-            config.allowUnfree = true;
-            overlays = [
-              inputs.emacs-overlay.overlay
-              inputs.nur.overlay
-              (final: prev: {
-                tools = {
-                  gerrit-hook = import ../tools/gerrit-hook final;
-                };
-              })
-            ];
-          };
-          # Add each input as a registry
-          nix.registry = inputs.nixpkgs.lib.mapAttrs'
-            (n: v:
-              inputs.nixpkgs.lib.nameValuePair (n) ({ flake = v; }))
-            inputs;
-        }
-      ];
-    };
-}