about summary refs log tree commit diff
path: root/hosts/work/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/work/default.nix')
-rw-r--r--hosts/work/default.nix26
1 files changed, 1 insertions, 25 deletions
diff --git a/hosts/work/default.nix b/hosts/work/default.nix
index 6cc3d5d..3db1e6f 100644
--- a/hosts/work/default.nix
+++ b/hosts/work/default.nix
@@ -1,31 +1,7 @@
-{ pkgs, ... }:
+{ ... }:
 {
   services.nix-daemon.enable = true;
 
-  nix = {
-    package = pkgs.nixFlakes;
-
-    gc = {
-      user = "root";
-      automatic = true;
-      interval.Day = 7;
-      options = "--delete-older-than 30d";
-    };
-
-    settings = {
-      trusted-users = [ "@admin" "fcuny" ];
-      experimental-features = [ "nix-command" "flakes" ];
-    };
-  };
-
-  # in order to install things like 1password's extensions
-  nixpkgs.config.allowUnfree = true;
-
-  # FIXME https://github.com/nix-community/nixd/issues/357
-  nixpkgs.config.permittedInsecurePackages = [
-    "nix-2.16.2"
-  ];
-
   programs.zsh.enable = true;
 
   users.users.fcuny.home = "/Users/fcuny";