about summary refs log tree commit diff
path: root/hosts/tahoe/services.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/tahoe/services.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/hosts/tahoe/services.nix b/hosts/tahoe/services.nix
index d497f82..4010094 100644
--- a/hosts/tahoe/services.nix
+++ b/hosts/tahoe/services.nix
@@ -80,4 +80,12 @@ in
 
     sendsms.enable = true;
   };
+
+  services.openssh.sftpServerExecutable = "internal-sftp";
+  services.openssh.extraConfig = ''
+    Match User backup
+      ChrootDirectory ${config.users.users.backup.home}
+      ForceCommand internal-sftp
+      AllowTcpForwarding no
+  '';
 }