about summary refs log tree commit diff
path: root/hosts/tahoe/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tahoe/hardware-configuration.nix')
-rw-r--r--hosts/tahoe/hardware-configuration.nix77
1 files changed, 39 insertions, 38 deletions
diff --git a/hosts/tahoe/hardware-configuration.nix b/hosts/tahoe/hardware-configuration.nix
index f7b0a73..d32ef0a 100644
--- a/hosts/tahoe/hardware-configuration.nix
+++ b/hosts/tahoe/hardware-configuration.nix
@@ -4,59 +4,60 @@
 { config, lib, pkgs, modulesPath, ... }:
 
 {
-  imports =
-    [ (modulesPath + "/installer/scan/not-detected.nix")
-    ];
+  imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
 
-  boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usbhid" "usb_storage" "sd_mod" ];
+  boot.initrd.availableKernelModules =
+    [ "xhci_pci" "ahci" "nvme" "usbhid" "usb_storage" "sd_mod" ];
   boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm-amd" ];
   boot.extraModulePackages = [ ];
 
-  fileSystems."/" =
-    { device = "/dev/disk/by-uuid/128c2a5e-48f6-4d94-b196-fb5db500b36d";
-      fsType = "btrfs";
-      options = [ "subvol=nixos" ];
-    };
+  fileSystems."/" = {
+    device = "/dev/disk/by-uuid/128c2a5e-48f6-4d94-b196-fb5db500b36d";
+    fsType = "btrfs";
+    options = [ "subvol=nixos" ];
+  };
 
-  boot.initrd.luks.devices."system".device = "/dev/disk/by-uuid/0d11e090-d88f-4313-8a41-8ef52eea0870";
+  boot.initrd.luks.devices."system".device =
+    "/dev/disk/by-uuid/0d11e090-d88f-4313-8a41-8ef52eea0870";
 
-  fileSystems."/home" =
-    { device = "/dev/disk/by-uuid/128c2a5e-48f6-4d94-b196-fb5db500b36d";
-      fsType = "btrfs";
-      options = [ "subvol=home" ];
-    };
+  fileSystems."/home" = {
+    device = "/dev/disk/by-uuid/128c2a5e-48f6-4d94-b196-fb5db500b36d";
+    fsType = "btrfs";
+    options = [ "subvol=home" ];
+  };
 
-  fileSystems."/.snapshots" =
-    { device = "/dev/disk/by-uuid/128c2a5e-48f6-4d94-b196-fb5db500b36d";
-      fsType = "btrfs";
-      options = [ "subvol=snapshots" ];
-    };
+  fileSystems."/.snapshots" = {
+    device = "/dev/disk/by-uuid/128c2a5e-48f6-4d94-b196-fb5db500b36d";
+    fsType = "btrfs";
+    options = [ "subvol=snapshots" ];
+  };
 
-  fileSystems."/boot" =
-    { device = "/dev/disk/by-uuid/CBB9-B788";
-      fsType = "vfat";
-    };
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/CBB9-B788";
+    fsType = "vfat";
+  };
 
-  fileSystems."/data/fast" =
-    { device = "/dev/disk/by-uuid/b9290b55-8ff6-4bd0-843d-a9e6f7a4df59";
-      fsType = "btrfs";
-    };
+  fileSystems."/data/fast" = {
+    device = "/dev/disk/by-uuid/b9290b55-8ff6-4bd0-843d-a9e6f7a4df59";
+    fsType = "btrfs";
+  };
 
-  boot.initrd.luks.devices."raid-fast".device = "/dev/disk/by-uuid/66c58a92-45fe-4b03-9be0-214ff67c177c";
+  boot.initrd.luks.devices."raid-fast".device =
+    "/dev/disk/by-uuid/66c58a92-45fe-4b03-9be0-214ff67c177c";
 
-  fileSystems."/data/slow" =
-    { device = "/dev/disk/by-uuid/0f16db51-0ee7-48d8-9e48-653b85ecbf0a";
-      fsType = "btrfs";
-    };
+  fileSystems."/data/slow" = {
+    device = "/dev/disk/by-uuid/0f16db51-0ee7-48d8-9e48-653b85ecbf0a";
+    fsType = "btrfs";
+  };
 
-  boot.initrd.luks.devices."raid-slow".device = "/dev/disk/by-uuid/d8b21267-d457-4522-91d9-5481b44dd0a5";
+  boot.initrd.luks.devices."raid-slow".device =
+    "/dev/disk/by-uuid/d8b21267-d457-4522-91d9-5481b44dd0a5";
 
   swapDevices =
-    [ { device = "/dev/disk/by-uuid/0f54b5ab-4fca-4c5a-a9eb-622553145163"; }
-    ];
+    [{ device = "/dev/disk/by-uuid/0f54b5ab-4fca-4c5a-a9eb-622553145163"; }];
+
+  my.hardware.amd = true;
 
-  hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
   # high-resolution display
   hardware.video.hidpi.enable = lib.mkDefault true;
 }