about summary refs log tree commit diff
path: root/hosts/tahoe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tahoe/default.nix')
-rw-r--r--hosts/tahoe/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/hosts/tahoe/default.nix b/hosts/tahoe/default.nix
new file mode 100644
index 0000000..1998a51
--- /dev/null
+++ b/hosts/tahoe/default.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, hostname, ... }:
+
+{
+  imports =
+    [ ./boot.nix ./hardware.nix ./networking.nix ./home.nix ./services.nix ];
+
+  users.groups.nas.gid = 5000;
+  users.users.nas = {
+    uid = 5000;
+    group = "nas";
+    isSystemUser = true;
+  };
+
+  # This value determines the NixOS release from which the default
+  # settings for stateful data, like file locations and database versions
+  # on your system were taken. It‘s perfectly fine and recommended to leave
+  # this value at the release version of the first install of this system.
+  # Before changing this value read the documentation for this option
+  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+  system.stateVersion = "21.11"; # Did you read the comment?
+}
+