about summary refs log tree commit diff
path: root/hosts/tahoe/boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tahoe/boot.nix')
-rw-r--r--hosts/tahoe/boot.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hosts/tahoe/boot.nix b/hosts/tahoe/boot.nix
new file mode 100644
index 0000000..f013f34
--- /dev/null
+++ b/hosts/tahoe/boot.nix
@@ -0,0 +1,17 @@
+{ ... }:
+
+{
+  boot = {
+    # get an IP address on boot, so we can unlock the root disk remotely
+    kernelParams = [ "ip=dhcp" ];
+    initrd = {
+      # driver for the NIC, required in order to get an IP address
+      kernelModules = [ "r8169" ];
+    };
+  };
+
+  my.system.boot = {
+    tmp = { clean = true; };
+    initrd = { network.enable = true; };
+  };
+}