about summary refs log tree commit diff
path: root/hosts/tahoe/boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tahoe/boot.nix')
-rw-r--r--hosts/tahoe/boot.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/hosts/tahoe/boot.nix b/hosts/tahoe/boot.nix
index f013f34..9bc68f7 100644
--- a/hosts/tahoe/boot.nix
+++ b/hosts/tahoe/boot.nix
@@ -2,8 +2,12 @@
 
 {
   boot = {
-    # get an IP address on boot, so we can unlock the root disk remotely
-    kernelParams = [ "ip=dhcp" ];
+    kernelParams = [
+      # get an IP address on boot, so we can unlock the root disk remotely
+      "ip=dhcp"
+      # rotate the screen 90 degree counter clockwise
+      "fbcon=rotate:1"
+    ];
     initrd = {
       # driver for the NIC, required in order to get an IP address
       kernelModules = [ "r8169" ];