about summary refs log tree commit diff
path: root/hosts/common/server/prometheus.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/common/server/prometheus.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/hosts/common/server/prometheus.nix b/hosts/common/server/prometheus.nix
index 05162a8..e85c242 100644
--- a/hosts/common/server/prometheus.nix
+++ b/hosts/common/server/prometheus.nix
@@ -10,10 +10,14 @@ let
           method = "GET";
           valid_status_codes = [ ];
           fail_if_not_ssl = true;
+          no_follow_redirects = false;
+          tls_config = { insecure_skip_verify = false; };
+          preferred_ip_protocol = "ip4";
         };
       };
       icmp = {
         prober = "icmp";
+        icmp = { preferred_ip_protoco = "ip4"; };
         timeout = "5s";
       };
     };
@@ -66,7 +70,7 @@ in {
         metrics_path = "/probe";
         params = { module = [ "icmp" ]; };
         static_configs =
-          [{ targets = [ "8.8.8.8" "1.1.1.1" "git.fcuny.net" ]; }];
+          [{ targets = [ "8.8.8.8" "1.1.1.1" "git.fcuny.net" "fcuny.net" ]; }];
         relabel_configs = [
           {
             source_labels = [ "__address__" ];