about summary refs log tree commit diff
path: root/hosts/common/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/common/nix.nix')
-rw-r--r--hosts/common/nix.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/hosts/common/nix.nix b/hosts/common/nix.nix
deleted file mode 100644
index c828a16..0000000
--- a/hosts/common/nix.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ pkgs, ... }: {
-  nix = {
-    package = pkgs.nixFlakes;
-
-    gc = {
-      user = "root";
-      automatic = true;
-      interval = { Weekday = 0; Hour = 2; Minute = 0; };
-      options = "--delete-older-than 30d";
-    };
-
-    settings = {
-      trusted-users = [ "@admin" "fcuny" ];
-      experimental-features = [ "nix-command" "flakes" ];
-    };
-  };
-
-  nixpkgs.config = {
-    allowUnfree = true;
-    permittedInsecurePackages = [
-      "nix-2.16.2" # FIXME https://github.com/nix-community/nixd/issues/357
-    ];
-  };
-}