about summary refs log tree commit diff
path: root/hosts/carmel/home.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/carmel/home.nix16
1 files changed, 4 insertions, 12 deletions
diff --git a/hosts/carmel/home.nix b/hosts/carmel/home.nix
index eb6c9ab..6fb5fc2 100644
--- a/hosts/carmel/home.nix
+++ b/hosts/carmel/home.nix
@@ -1,14 +1,6 @@
-{ ... }: {
-  my.home = {
-    # default packages I want on all hosts
-    packages.enable = true;
+{ self, ... }: {
 
-    # terminal
-    shell.name = "zsh";
-    ssh.enable = true;
-    tmux.enable = true;
-
-    # software development
-    git.enable = true;
-  };
+  imports = [
+    "${self}/home/modules/home.nixhome"
+  ];
 }