about summary refs log tree commit diff
path: root/hosts/carmel/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/carmel/default.nix')
-rw-r--r--hosts/carmel/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/hosts/carmel/default.nix b/hosts/carmel/default.nix
new file mode 100644
index 0000000..87ad97d
--- /dev/null
+++ b/hosts/carmel/default.nix
@@ -0,0 +1,23 @@
+{ config, pkgs, hostname, ... }:
+
+{
+  imports = [
+    ./hardware.nix
+    ./boot.nix
+    ./sound.nix
+    ./networking.nix
+    ./home.nix
+    ./profile.nix
+  ];
+
+  hardware.opengl.driSupport = true;
+
+  # This value determines the NixOS release from which the default
+  # settings for stateful data, like file locations and database versions
+  # on your system were taken. It‘s perfectly fine and recommended to leave
+  # this value at the release version of the first install of this system.
+  # Before changing this value read the documentation for this option
+  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+  system.stateVersion = "21.11"; # Did you read the comment?
+}
+