about summary refs log tree commit diff
path: root/hosts/carmel/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/carmel/default.nix')
-rw-r--r--hosts/carmel/default.nix20
1 files changed, 4 insertions, 16 deletions
diff --git a/hosts/carmel/default.nix b/hosts/carmel/default.nix
index d728d6b..1413f1f 100644
--- a/hosts/carmel/default.nix
+++ b/hosts/carmel/default.nix
@@ -5,6 +5,8 @@
     [ # Include the results of the hardware scan.
       ./hardware-configuration.nix
       ../common/desktop
+      # In order to unlock the root disk remotely
+      ../common/system/boot-ssh.nix
     ];
 
   # Use the systemd-boot EFI boot loader.
@@ -13,25 +15,11 @@
 
   boot.initrd = {
     luks.devices."system".allowDiscards = true;
-    network = {
-      enable = true;
-      postCommands = ''
-        echo "cryptsetup-askpass; exit" > /root/.profile
-      '';
-      ssh = {
-        enable = true;
-        port = 2222;
-        hostKeys = [
-          /etc/ssh/ssh_host_ed25519_key
-          /etc/ssh/ssh_host_rsa_key
-        ];
-      };
-    };
   };
 
-  time.timeZone = "America/Los_Angeles";
+  boot.kernelParams = [ "ip=dhcp" ];
 
-  services.xserver.dpi = 168;
+  time.timeZone = "America/Los_Angeles";
 
   hardware.opengl.driSupport = true;