about summary refs log tree commit diff
path: root/hosts/carmel/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/carmel/default.nix24
1 files changed, 11 insertions, 13 deletions
diff --git a/hosts/carmel/default.nix b/hosts/carmel/default.nix
index 0234e90..ecc8362 100644
--- a/hosts/carmel/default.nix
+++ b/hosts/carmel/default.nix
@@ -1,13 +1,13 @@
 { config, pkgs, hostname, ... }:
 
 {
-  imports =
-    [ # Include the results of the hardware scan.
-      ./hardware-configuration.nix
-      ../common/desktop
-      # In order to unlock the root disk remotely
-      ../common/system/boot-ssh.nix
-    ];
+  imports = [ # Include the results of the hardware scan.
+    ./hardware-configuration.nix
+    ./sound.nix
+    ../common/desktop
+    # In order to unlock the root disk remotely
+    ../common/system/boot-ssh.nix
+  ];
 
   boot = {
     # get an IP address on boot, so we can unlock the root disk remotely
@@ -27,13 +27,11 @@
     networks = {
       enp9s0 = {
         matchConfig.Name = "enp9s0";
-        networkConfig = {
-          DHCP = "yes";
-        };
+        networkConfig = { DHCP = "yes"; };
         extraConfig = ''
-         [DHCPv4]
-         UseDNS=yes
-         UseDomains=yes
+          [DHCPv4]
+          UseDNS=yes
+          UseDomains=yes
         '';
       };
     };