about summary refs log tree commit diff
path: root/hosts/carmel/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/carmel/configuration.nix')
-rw-r--r--hosts/carmel/configuration.nix44
1 files changed, 0 insertions, 44 deletions
diff --git a/hosts/carmel/configuration.nix b/hosts/carmel/configuration.nix
deleted file mode 100644
index d009831..0000000
--- a/hosts/carmel/configuration.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{ config, pkgs, ... }:
-
-{
-  imports =
-    [ # Include the results of the hardware scan.
-      ./hardware-configuration.nix
-      ../../modules/systems
-      ../../modules/desktop
-    ];
-
-  nix = {
-    package = pkgs.nixUnstable;
-  };
-
-  # Use the systemd-boot EFI boot loader.
-  boot.loader.systemd-boot.enable = true;
-  boot.loader.efi.canTouchEfiVariables = true;
-
-  time.timeZone = "America/Los_Angeles";
-
-  networking.hostName = "carmel"; # Define your hostname.
-
-  networking.wireless.enable = false;
-  networking.interfaces.enp9s0.useDHCP = true;
-  networking.interfaces.wlp8s0.useDHCP = true;
-  # TODO: If set to false, systemd hangs on boot, unclear why.
-
-  services.xserver.dpi = 168;
-
-  # Use systemd-resolved
-  services.resolved = {
-    enable = true;
-    dnssec = "false";
-  };
-
-  # This value determines the NixOS release from which the default
-  # settings for stateful data, like file locations and database versions
-  # on your system were taken. It‘s perfectly fine and recommended to leave
-  # this value at the release version of the first install of this system.
-  # Before changing this value read the documentation for this option
-  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
-  system.stateVersion = "21.11"; # Did you read the comment?
-}
-