about summary refs log tree commit diff
path: root/hosts/carmel/boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/carmel/boot.nix')
-rw-r--r--hosts/carmel/boot.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/carmel/boot.nix b/hosts/carmel/boot.nix
new file mode 100644
index 0000000..606215e
--- /dev/null
+++ b/hosts/carmel/boot.nix
@@ -0,0 +1,14 @@
+{ ... }:
+
+{
+  boot = {
+    # get an IP address on boot, so we can unlock the root disk remotely
+    kernelParams = [ "ip=dhcp" ];
+    initrd = {
+      # driver for the NIC, required in order to get an IP address
+      kernelModules = [ "igb" ];
+    };
+  };
+
+  my.system.boot = { initrd = { network.enable = true; }; };
+}