about summary refs log tree commit diff
path: root/hosts/aptos/services.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/aptos/services.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/hosts/aptos/services.nix b/hosts/aptos/services.nix
deleted file mode 100644
index 742b014..0000000
--- a/hosts/aptos/services.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ config, ... }:
-let
-  secrets = config.age.secrets;
-  ssh-key-path = secrets."restic/ssh-key".path;
-in
-{
-  my.services = {
-    backup = {
-      enable = true;
-      repository = "sftp:192.168.6.40:/aptos";
-      exclude = [
-        # paths that I don't want to backup
-        "/home/fcuny/workspace/tmp"
-
-        # various development related files
-        "**/target"
-        "**/.direnv"
-        "**/result"
-      ];
-      timerConfig = { OnCalendar = "06:30"; };
-      passwordFile = secrets."restic/repo-users".path;
-      extraOptions = [
-        "sftp.command='ssh backup@192.168.6.40 -i ${ssh-key-path} -s sftp'"
-      ];
-      paths = [
-        "/home/fcuny/workspace"
-        "/home/fcuny/media"
-        "/home/fcuny/documents"
-      ];
-    };
-  };
-}